Chat / support@radicenter.eu

PHP versiot ja niiden käyttö cPanel palvelimilla

Asiakkaat ovat kysyneet meiltä, onko mahdollista muokata PHP versioita cPAnel tilin kautta per verkkotunnus.
Kyllä on se mahdollista cPanelin kautta, kuin myös komentoriviltä:

Lisätietoja:
WordPress ja Joomla antaa nykyisin herjaviesti PHP versioista asiakkaille, kenellä on vanhempi PHP versio käytössä verkkosivulla..
Meidän palvelimilla on käytössä eri-PHP versiot, jossa tietoturvapäivitykset on myös vanhempille PHP versioille.
Enemmän tietoa asiasta löytyy sivulta:
https://www.cloudlinux.com/hardenedphp
(Jos verkkosivu ja sen lisäosat/teemat toimii myös uudemmalla PHP versiolla, suosittelen sittenkin päivittää PHP version!)

1. PHP version päivitys cPanel tililla

1. Kirjaudu cPanel tilille
2. Valikoista menee ”MultiPHP manager” alle
3. Laita ruksi verkkotunnuksen eteen ja oikealla olevasta valikoinnista ota sopiva PHP versio ja klikkaa napille ”Apply”
(Uusi PHP versio pitäisi toimia heti)
NB! Edellinen tallentaa ne asetukset verkkotunnuksen kansioon .htaccess tiedostoon! Jos muokkaat itse tulevaisuudessa .htaccess tiedostoa tai tekee sen automaattisesti jokin skripti – pitäisi tallentaa ne PHP asetukset joka kerta uudestaan!

2. Halutun PHP’n version kautta komentoriviltä PHP’n käyttö (toimii myös CRON’issa)

Esimerkkejä komennoista sopivalla PHP versiolla:

CRON'in kautta:
/usr/local/bin/ea-php53 /kansio/missä/haluttu/skripti.php
/usr/local/bin/ea-php56 /kansio/missä/haluttu/skripti.php
/usr/local/bin/ea-php70 /kansio/missä/haluttu/skripti.php
----
Komentoriviltä:
php -ea_php 53 /kansio/missä/haluttu/skripti.php
php -ea_php 56 /kansio/missä/haluttu/skripti.php
php -ea_php 70 /kansio/missä/haluttu/skripti.php

Käytössä olevat PHP versiot ovat PHP: 5.3 = 53 , 5.6 = 56 , 7.0 = 70, 7.1 = 71, 7.2 = 72, 7.3 = 73

Comments are currently closed.

Tämä verkkosivusto käyttää evästeitä ja vastaavia tekniikoita toiminnallisuuteen ja muihin tarkoituksiin. Tämän sivuston käyttö tarkoittaa evästeiden hyväksymistä.
Hyväksyn.