Verkkosivusto ei toimi – päivitetty PHP versio – Error: reference/function is deprecated Edit this entry

01.01.2014 päivitimme palvelimen PHP version. Uusi versio: 5.3.28 .
Muutoksesta on lähetetty ilmoitukset:
11.12.2013
11.02.2013
07.04.2013

Muutos oli alunperin tarkoitettu toteuttaa 1. tammikuuta 2013, mutta sitä siirrettiin asiakkaiden pyynnöstä Enää ei ollut mahdollista lykätä päivitystä, koska veriso PHP 5.2 ei ole virallisesti ollut tuettu jo kolme vuotta .

Ilmoitukset on lähetetty asiakkaiden tilien yhteys sähköpostiosoitteisiin:


Arvoisa asiakas

Lähetämme sinulle tärkeää tietoa palvelusta ja tulevista muutoksista, joihin pitäisi kiinnittää huomiota.

PÄIVITYS PHP 5.2-stä PHP 5.3: lle 31. JOULUKUUTA 2013
Koska PHP versio 5.2 on vanhentunut, eikä se ole enää virallisesti tuettu kehittäjien toimesta, meidän on päivitettävää kaikkien palvelinten PHP versioon 5.3. Päivitys tapahtuu 31. joulukuuta 2013.

Useimmiten kaikki PHP skriptit toimivat uudistuksen jälkeenkin, mutta voi olla, että jokin skripti kuitenkin lakkaa toimimasta. Jos käytät valmis sovellusta (Joomla, WordPress, Drupal, Gallery jne..), riittää, kun päivität ohjelmiston uusimman version. Jos käytät omaa skriptiä, sinun on muutettava skriptiä uuden PHP version vaatimusten mukaiseksi tai annettava tehtävä koodin kehittäjälle. Lisätietoa PHP 5.3 muutoksesta on saatavilla PHP:n kehittäjän verkkosivuilla:
http://php.net/eol.php
http://www.php.net/manual/en/migration53.php

Jos teidän kotisivuilla on virheilmoitus:  ” … reference is deprecated …” ja teidän sivuston/domainin hallintapanlein osoite on https://212.47.208.158:2222/ – sivustolla on käytössä vanhentunmut sisällönhallintaohjelma, joka käyttää vanhentuneita PHP:n toimintoja, mutta ei toimi uudessa PHP 5.3.28 ympäristössä.

Mitä tulisi tehdä :

Kehotamme sinua ottamaan yhteyttä kotisivun tekijään ja pyytämään häneltä päivitystä:

1. Jos käytätte valmiita ohjelmistoja ( Joomla , WordPress , Drupal , Gallery , ym.. ) , riittää yleensä päivittäminen uusimpaan ohjelmiston versioon .

2 Jos käytätte itse rakennettuja skriptejä , teidän tulisi muuttaa skriptit uudeman PHP version vaatimusten mukaiseksi.

Kysymyksiä / vastauksia

K: En ole hyväksy tätä muutosta, miksi se oli tarpeellinen?
V: Koska PHP versio 5.2 ei ole enää virallisesti tuettu ja turvallinen, jouduime päivittämään PHP versioon, johon saatavalilla turvallisuuspäivityksiä. Asiakkaille ilmoitettiin muutoksesta ajoissa.

K: Olisiko silti mahdollista aktivoida tai palauttaa vanhempi PHP versio?
V: Ei. Kaikki radicenterin palvelimet käyttävät turvallisempaa PHP 5.3.28 versiota emekä voi aktivoida palvelimilla uudelleen epäturvallisia sovelluksia.

K: En ole saanut kyseistä ilmoitusta.
V: Radicenter on lähettänyt ilmoituksen kaikille asiakkaille, joitten tili sijaitsee kyseisellä palvelimella 212.47.208.158. Viesti lähetettiin osoitteeseen, joka on merkitty tilin pää yhteyssähköposti osoitteeksi.

Jos on käynyt niin, että et ole saanut kyseistä viestiä:

1. Tarkistakaa, että tilin yhteyshenkilön sähköpostiosoite on oikea ja toimiva.
2. Tarkistakaa roskaposti-kansio (esimerkiksi Gmail joskus suodattaa sellaiset ilmoitukset roskapostiksi)

Comments are currently closed.