PHP versiot ja päivitykset DirectAdmin palvelimilla

Seuraava tieto koskee PHP version päivityksiä Radicenterin palvelimilla.
(Alkaen 15.09.2014 on kaikilla palvelimilla mahdollista valita eri PHP versioiden välillä)

Miten käyttää eri PHP versioita:
– Domainin PHP version muuttamisen ohjeen löydätte  TÄÄLTÄ
– Jos haluatte testata eri php versioiden toimivuutta, silloin riittää, jos muuttaa tiedoston tarkentinta .php muotoon .phpXX , jossa XX on php versionumero
(Esimerkiksi: PHP 5.5 testaamiseksi pitäisi tarkentimen olla .php55)

– PHP oletuspolku on:
PHP 5.3: /usr/local/php53/bin/php
PHP 5.5: /usr/local/php55/bin/php tai /usr/local/bin/php ( <- suosittelemme käyttää viimeistä – aina ajankohtainen! )

– PEAR oletuspolku on:
/usr/local/php53/lib tai /usr/local/php55/lib <- riippuu PHP versiosta!

Radicenterin palvelimet ja PHP versioiden tuki:
5.6 – Todennäköisesti lisätään palvelimille 5.4 virallisen tuen päätyttyä.
5.513.09.2014 kuni …
5.401.03.2015 kuni … 2015
5.3 – 01.01.2014 – 31.12.2014 (Epävirallisesti on PHP 5.3 palvelimilla kunnes v. 2018 loppuun saakka <- NB! Aikamäärä voi muuttua ilman tiedotusta)
PHP 5.5 (Tällä hetkellä (alkaen 08.01.2015) oletusversio kaikilla palvelimilla)
PHP 5.4
PHP 5.3

PHP 5.5

Saatavilla palvelimilla alkaen 15.09.2014.
5.4 > 5.5http://ee1.php.net/migration55
Oletuksena uusin PHP valinta kaikilla palvelimilla alkaen 15.09.2014. Mahdollista valita domainkohtaisesti (Ohje TÄÄLLÄ)

PHP 5.4

Saatavilla palvelimilla heti PHP5.3 tuen päättymisen jälkeen – 01.01.2015.
5.3 > 5.4http://ee1.php.net/migration54

PHP 5.3

– PHP 5.3 virallinen tuki päättyi 14 elokuuta 2014 (http://php.net/eol.php).
– Meidän palvelimilla on mahdollista käyttää versiota 5.3 VIELÄ VUODEN 2018 LOPPUUN ASTI. Tällä hetkellä olemme asentaneet palvelimille viimeisen turvallisuuspäivityksen kyseiselle PHP versiolle. viimane turvapaik antud PHP versioonile.
01.01.2015 alkaen palvelimille lisätään PHP 5.3 sijaan vanhempi tuettu versio eli PHP 5.4

Lisätiedot PHP versioiden muutoksista seuraavilla sivuilla:
5.3 > 5.4http://ee1.php.net/migration54
5.4 > 5.5http://ee1.php.net/migration55

Miksi ei ole mahdollista testata PHP 5.3 > PHP 5.4 migraatiota heti?
1. PHP 5.4 on kyllä suurempi päivitys (muutos versiosta 5.3) mutta PHP 5.5:n mukana tulee vielä lisämuutoksia / korjauksia. PHP 5.5 toimivat melkein kaikki 5.4 version ominaisuudet.
2. PHP 5.4 tuen ”virallinen suunniteltu loppu” on vuonna 2015 – sen elinkaari ei tule olemaan kovin pitkä. PHP 5.5 virallisen tuen suunniteltu päättyminen on vuonna 2016

 

Comments are currently closed.